Which of the following are possible causes (Choose Two)?

An administrator finds that scans on virtual machines that were part of a recently completed remediation show that they are still non-compliant. The remediation shows that it completed successfully on the remaining virtual machines. Which of the following are possible causes (Choose Two)?

A.
VMware Tools is not installed on the affected virtual machines

B.
Insufficient disk space exists on the virtual machine for one or more updated in the baseline

C.
The updates that are part of the baseline conflict with running applications

D.
The updates that are part of the baseline are not applicable to the affected virtual machines

Explanation:
Administration Guide Update Manager, page 32. Remediated Updates Continue to be NonCompliant For Windows virtual machines, check the registry to ensure that the updates were not installed. Search for the Microsoft Knowledge Base (KB) number that pertains to the update in question. These numbers are in:

* The virtual machine’s registry in: HKLMSoftwareMicrosoftUpdatesKB Number
* The virtual machine’s file system in: C:WindowsNTUninstallKB Number Common explanations for this problem include:
* Insufficient disk space for Service Pack installation. Retry remediation after freeing up disk space.
* Conflicts with running applications. Reboot the virtual machine and then retry the remediation operation

One Comment on “Which of the following are possible causes (Choose Two)?

  1. Clay says:

    Ignore this is a VCP4 only question… UM5 no longer supports patching the OS or applications withing the OS

    http://pubs.vmware.com/vsphere-50/topic/com.vmware.vsphere.update_manager.doc_50/GUID-F7191592-048B-40C7-A610-CFEE6A790AB0.html

    Installing and Administering VMware vSphere Update Manager provides information about installing, configuring, and using VMware® vSphere Update Manager to scan and remediate the objects in your vSphere environment. It also describes the tasks that you can perform to update your vSphere inventory objects and make them compliant against attached baselines and baseline groups.

    For scanning and remediation, Update Manager works with the following ESX/ESXi versions.

    For VMware Tools and virtual machine hardware upgrade operations, Update Manager works with ESX/ESXi version 4.0 and later.

    For ESX/ESXi host patching operations, Update Manager works with ESX/ESXi 3.5 and later.

    For ESX/ESXi host upgrade and migration operations, Update Manager works with ESX/ESXi 4.0 and later.

    Note

    Update Manager 5.0 does not support virtual machine patch operations.


Leave a Reply

Your email address will not be published. Required fields are marked *