PrepAway - Latest Free Exam Questions & Answers

What will happen if R1 receives a packet destined to 192.168.3.1 ?

Refer to the exhibit. In this network, R1 has been configured to advertise a summary route,
192.168.0.0/22, to R2. R2 has been configured to advertise a summary route, 192.168.0.0/21, to
R1. Both routers have been configured to remove the discard route (the route to null created when
a summary route is configured) by setting the administrative distance of the discard route to 255.
What will happen if R1 receives a packet destined to 192.168.3.1 ?

PrepAway - Latest Free Exam Questions & Answers

A.
The packet will loop between R1 and R2.

B.
It is not possible to set the administrative distance on a summary to 255.

C.
The packet will be forwarded to R2, where it will be routed to null0.

D.
The packet will be dropped by R1, since there is no route to 192.168.3.1.

Explanation:
Indeed, when you change the administrative distance of the discard route to 255, this prevents the
route to be installed in the routing table but this does not prevent the route to be advertised to the
other peer!
From the Cisco website:
“You can configure a summary aggregate address for a specified interface. If there are any more
specific routes in the routing table, EIGRP will advertise the summary address out the interface
with a metric equal to the minimum of all more specific routes”
And don’t forget YOU HAVE a directly connected route 192.168.1/24 in R1 and .4/24 in R2.
Then your summary is advertised, and the packet loop between R1 and R2.
If you do the test with GNS3, you will see via “show ip eigrp topology” that you FD of your local
subnet 192.168.1.0/24 in R1 become the metric of the summary route “192.168.0.0/22 advertise to
R2 ! And viceversa. Numerically, an administrative distance is an integer from 0 to 255. In general,
the higher the value, the lower the trust rating. An administrative distance of 255 means that the
routing information source cannot be trusted at all and should be ignored.
http://www.cisco.com/en/US/docs/ios/12_3/iproute/command/reference/ip2_c1g.html
A route with an AD of 255 would never be installed in the RIB. It is much better for the router to

forward a packet to null0 following the default route than for the router to find out it has no route to
destination, drop the packet and probably to send an ICMP unreachable message back to the
source of that packet.
https://supportforums.cisco.com/thread/192416
You should not use the ip summary-address eigrp summarization command to generate the
default route (0.0.0.0) from an interface. This causes the creation of an EIGRP summary default
route to the null 0 interface with an administrative distance of 5. The low administrative distance of
this default route can cause this route to displace default routes learned from other neighbors from
the routing table. If the default route learned from the neighbors is displaced by the summary
default route, or if the summary route is the only default route present, all traffic destined for the
default route will not leave the router, instead, this traffic will be sent to the null 0 interface where it
is dropped.
http://www.cisco.com/en/US/docs/ios/12_0/np1/configuration/guide/1ceigrp.html#wp4937

Here are the configurations and CLI output to prove the answer is A. This is done on IOS 12.4T
train of code.
R1

interface Loopback0
ip address 192.168.1.1 255.255.255.0
!
interface FastEthernet0/0
ip address 10.1.2.1 255.255.255.0
ip summary-address eigrp 1 192.168.0.0 255.255.252.0 255

!
router eigrp 1
network 10.0.0.0
network 192.168.1.0
no auto-summary
R2

interface Loopback0
ip address 192.168.4.2 255.255.255.0
!
interface FastEthernet0/0
ip address 10.1.2.2 255.255.255.0
ip summary-address eigrp 1 192.168.0.0 255.255.248.0 255
!
router eigrp 1
network 10.0.0.0
network 192.168.4.0
no auto-summary
Show Output
———–
Look at R1 s routing table…notice it does NOT have the summary route to null0 for 192.168.0.0/22
because we
have disabled it. It does have a summary route to 192.168.0.0/21 from R2 it is receiving…
R1#show ip route | b Gateway
Gateway of last resort is not set
10.0.0.0/24 is subnetted, 1 subnets
C 10.1.2.0 is directly connected, FastEthernet0/0
C 192.168.1.0/24 is directly connected, Loopback0
D 192.168.0.0/21 [90/156160] via 10.1.2.2, 00:03:45, FastEthernet0/0
Now look at R2 s routing table. Notice it does NOT have a summary route to null0 for the
192.168.0.0/21 because we disabled it. It does however have a route for 192.168.0.0/22 received
from R1.
R2#sh ip route | b Gateway
Gateway of last resort is not set
C 192.168.4.0/24 is directly connected, Loopback0
10.0.0.0/24 is subnetted, 1 subnets
C 10.1.2.0 is directly connected, FastEthernet0/0
D 192.168.0.0/22 [90/156160] via 10.1.2.1, 00:05:36, FastEthernet0/0
Now, what will happen? As I said — When R1 pings 192.168.3.1 it will look in its routing table, and
it will see the

EIGRP route 192.168.0.0/21 from R2 so it will send the packet to R2 since 192.168.3.1 is part of
that summary.
R2 will get the packet and look in its routing table. It will find an EIGRP route for 192.168.0.0/22
from R1 and route the packet back to R1 since 192.168.3.1 is within that summary range.
This continues in a loop until the IP TTL expires.
Traceroute from R1. Notice it goes to R2 then right back to R1…Hope this helps! —————-
R1#trace 192.168.3.1
Type escape sequence to abort.
Tracing the route to 192.168.3.1
1 10.1.2.2 0 msec 0 msec 4 msec
2 10.1.2.1 0 msec 0 msec 4 msec
3 * * *


Leave a Reply