Juniper Exam Questions

Which configuration supports interprovider Layer 3 V…

Click the Exhibit button.

Which configuration supports interprovider Layer 3 VPN option B on ASBR1 as shown in the exhibit.

A.
[edit]
user@router# show
interfaces {
ge-1/0/0 {
unit 0 {
family inet {
address 10.0.0.1/31;
}
family mpls;
}
}
}
routing-options {
autonomous-system 1;
}
protocols {
mpls {
interface ge-1/0/0.0;
}
bgp {
group ebgp {
family inet {
unicast;
}
family inet-vpn {
unicast;
}
neighbor 10.0.0.2 {
peer-as 2;
}
}
}}

B.
[edit]
user@router# show
interfaces {
ge-1/0/0 {
unit 0 {
family inet {
address 10.0.0.1/31;
}
family mpls;
}
}
}
routing-options {
autonomous-system 1;
}
protocols {
mpls {
interface ge-1/0/0.0;
}
bgp {
group ebgp {
family inet {
unicast;
}
family route-target;{
neighbor 10.0.0.2 {
peer-as 2;
}
}
}
}

C.
[edit]
user@router# show
interfaces {
ge-1/0/0 {
unit 0 {
family inet {
address 10.0.0.1/31;
}
}
}
}
routing-options {
autonomous-system 1;
}
protocols {
mpls {
interface ge-1/0/0.0;
}
bgp {
group ebgp {
family inet {
unicast;
}
family inet-vpn {
unicast;
}
neighbor 10.0.0.2 {
peer-as 2;}
}
}
}

D.
[edit]
user@router# show
interfaces {
ge-1/0/0 {
unit 0 {
family inet {
address 10.0.0.1/31;
}
family mpls;
}
}
}
routing-options {
autonomous-system 1;
}
protocols {
mpls {
interface ge-1/0/0.0;
}
bgp {
group ebgp {
family inet {
labeled-unicast;
}
neighbor 10.0.0.2 {
peer-as 2;
}
}
}
}

Explanation:
Specify the mpls address family on the Fast Ethernet interface.
Specify the inet-vpn address family and unicast traffic type to enable BGP to carry IPv4 network layer
reachability information (NLRI) for VPN routes.
Incorrect Answers:
B, D: BGP is the configured inet address family, but inet-vpn is required.
C: The interface lacks the family mpls statement.
https://www.juniper.net/documentation/en_US/junos16.1/topics/example/mpls-vpn-option2-
configuration.html